Curse you chrome caching and qunit for not catching this earlier |
|
More...
|
over 12 years ago
|
Merge branch 'master' of github.com:flyingclimber/JSChip8 |
|
More...
|
over 12 years ago
|
Bad tomasz didn't update the unit tests after last refactoring. No biscuit for me |
|
More...
|
over 12 years ago
|
Adding masks for all arithmetic operations to catch overflows |
|
More...
|
over 12 years ago
|
Renaming emulateCycle() to decodeOpcode() |
|
More...
|
over 12 years ago
|
Moving chip8Cycle() and updateTimers() around to make the code easier to read |
|
More...
|
over 12 years ago
|
Renaming drawGraphics() to updateGraphics() to be consistent |
|
More...
|
over 12 years ago
|
Refactor: Moving setupGraphics() and loadFile() to make the code easier to read |
|
More...
|
over 12 years ago
|
Removing setKeys() as we don't use it anymore |
|
More...
|
over 12 years ago
|
Simplyfing var i declarations |
|
More...
|
over 12 years ago
|
Renaming resetTimers() to clearTimers() to be consistent |
|
More...
|
over 12 years ago
|
Renaming clearAllRegisters() to clearRegisters() as we dont have a function for clearing a single register |
|
More...
|
over 12 years ago
|
Refactor: Adding a setKey() function so that we don't need two giant keyUp and keyDown functions |
|
More...
|
over 12 years ago
|
Removing var in front of i defs |
|
More...
|
over 12 years ago
|
Forgot a couple more == and != |
|
More...
|
over 12 years ago
|
Adding brackets to if in 0xD000 |
|
More...
|
over 12 years ago
|
Adding missing semicolon to loadFile() |
|
More...
|
over 12 years ago
|
Updating all == and != to === and !== |
|
More...
|
over 12 years ago
|
Standardizing on spacing for for loops |
|
More...
|
over 12 years ago
|
Standardizing spacing for if statements |
|
More...
|
over 12 years ago
|
Changing setInterval calls to be more jslint friendly |
|
More...
|
over 12 years ago
|
Standardize on camelCase for all vars |
|
More...
|
over 12 years ago
|
Changing to literal array definitions |
|
More...
|
over 12 years ago
|
Removing unused comments |
|
More...
|
over 12 years ago
|
Removing unused timePrevious and timeCurrent |
|
More...
|
over 12 years ago
|
Adding a license |
|
More...
|
over 12 years ago
|
Renaming detectKey() to keyDown() and adding keyUp() |
|
More...
|
over 12 years ago
|
Merge branch 'master' into keyboard |
|
More...
|
over 12 years ago
|
Fixing bug were we wouldn't lookup the correct int value of key in 0xEX9E and 0xEXA1 |
|
More...
|
over 12 years ago
|
Removing need for opcodes and cpuCycleCount as 914f9a0368092d62948d432459d4c33226715700 makes it obsolete |
|
More...
|
over 12 years ago
|